Quotation marks are omitted
#1
Just a friendly bug report for Quirkos v1.5.2 (signed 13-Aug-2018) and running Windows 10 Pro x64 version 1803.

When quotation marks are present in a source document, strange things happen when when importing from a CSV file (i.e., using Structured Questions): 
  • In the case of double quotes ( " ), they are silently omitted as if they simply were not there. 
  • In the case of single quotes ( ' ), they are also omitted, but additionally strange results appear after the import, such as the merging of two cells into one (thus leaving holes in the questions where data should be) and adding a comma between the two question responses. Please see the attached screenshots and XLSX* file for clarification.
In both cases, the quotes can successfully be re-inserted using Quirkos (i.e., the edit is retained), and the problem does not appear when importing the source as a docx (i.e., not using Structured Questions).

-Ryan

*P.S. This forum won't accept CSV file attachments, but note that I created the CSV file by saving the attached XLSX file as a "CSV UTF-8 (comma delimited) (*.csv)" using Word 2016 (installed locally via Office 365).

Screenshot 1 
.png   QuotesTest_SingeQuoteStrangeness.png (Size: 452.72 KB / Downloads: 0)


Screenshot 2 
.png   QuotesTest_DoubleQuotesOmitted.png (Size: 447.95 KB / Downloads: 0)


Spreadsheet with data
.xlsx   TestSources.xlsx (Size: 9.62 KB / Downloads: 1)
Reply
#2
Thanks for providing an example file Ryan, I can see the same problem in Windows and we are looking into it.

Daniel
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)